Toilet & Shower Problems

Submitted: Saturday, Dec 15, 2012 at 07:10
ThreadID: 128444 Views:1934 Replies:5 FollowUps:1
This Thread has been Archived
We are currently in Broome. We have a problem with our Tetford toilet in that it will not flush and I suspect it is the switch. Any other ideas what could be the cause would be appreciated.
We also have a problem with the shower in that I can pump water to the heater but unable to have a shower with water under pressure.
After discovering that the shower was not working I replaced the anode and cleared a majority of the old anode residue from the heater and from the fine filter near the shower head to no avail. Any ideas please.
Does anyone know a caravan repairer(s) in Broome.
Thanks. Greg.
Back Expand Un-Read 0 Moderator

Reply By: Tassie Bushies - Saturday, Dec 15, 2012 at 08:56

Saturday, Dec 15, 2012 at 08:56
Hi Greg,
Toilet
try the fuse, it may be - (Hard to get at) halfway along the wall when you have taken the cassette out. but otherwise you need to supply more info, what model etc? have you checked the bog bible?

Shower
- seems you have a blockage somewhere, you need to chase it backwards after you have checked, are all other taps working? how much mullock is in their filters? If they work & filters are clean try-
first;take shower head off/
take hose off/
check pipe to fitting/
flush out hot tank more thoroughly,
A man just needs a shower to wash away all that sunshine up the top end.
Regards Peter.

Member
My Profile  Send Message
Moderator

AnswerID: 585156

Reply By: Grumblebum & Dragon - Saturday, Dec 15, 2012 at 18:23

Saturday, Dec 15, 2012 at 18:23
The toilet flushing issue could also be (a) something jamming the impeller of the pump or the pump is U/S. I had to replace my pump a while ago - and I also bypassed the switch and put my own in

John
AnswerID: 585157

Reply By: NIK `N` OFF - Saturday, Dec 15, 2012 at 21:26

Saturday, Dec 15, 2012 at 21:26
Greg, we have had two Thetford toilets in our BT, Original was the C2 which always had problems with the flush and was always one of the micro switches, after changing switches twice in 4.5 years and then having it fail again we had a new C402 loo fitted, but it too has had flush problems but it was a lot easier to fix as the control panel is on top off the loo instead of tucked up high in the cassette compartment like the C2. Parts were posted to me [warranty]

So it depends on what model you have

Regarding the shower it sounds like a process of elimination to see where you can get water to.

Cheers
Mick & Vickie

www.niknoff.com

Member
My Profile  My Blog  Send Message

AnswerID: 585158

Reply By: GoinThere - Sunday, Dec 16, 2012 at 23:52

Sunday, Dec 16, 2012 at 23:52
Hi Greg, I have had simialr probs with the flush and found removing the impeller and rinsing in clean water generally fixes the problem. It only takes a small amount of foreign material to stop the impeller.
Terry
AnswerID: 585159

Follow Up By: Noosa Fox - Tuesday, Dec 18, 2012 at 04:18

Tuesday, Dec 18, 2012 at 04:18
I agree with you Terry, We took the hint up of putting nappy san in the top tank and I believe that it causes calcification on the impeller and prevents it turning.
Ours was working when we put it away 3 months ago and not when we first went to use it on this trip. A bit of a clean with a small screw driver and turn and it is working again.

Brian
Enjoying the friendship of BOG members

Member
My Profile  My Blog  Send Message

0
FollowupID: 854825

Reply By: Finch's nest - Sunday, Dec 16, 2012 at 23:54

Sunday, Dec 16, 2012 at 23:54
Greg,
Go to www.thetford.com.au
Go into WELCOME TO THETFORD AUSTRALIA
Click on" Service Documentation"
Then Righthand side click on" Trouble shooting guide " go in and find the model you have .
If no good go back to contact us.
Or phone thetford 0393580700 James is most helpfull.

regards Clive

AnswerID: 585160

Our Sponsors